Webデザイン

gulpエラー Browserslist: caniuse-lite is outdated. Please run:npx browserslist@latest –update-db

Webデザイン
Browserslist: caniuse-lite is outdated. Please run:
npx browserslist@latest --update-db

Browserslist を更新しろというエラーです。
メッセージに従いコマンドプロンプトでnpx browserslist@latest --update-dbを実行すると解決します。

C:\Users\kenyo_c\Documents\site\xxx>npx browserslist@latest --update-db

以下のメッセージが出力され更新が完了となります。

npx: installed 6 in 55.927s
Browserslist: caniuse-lite is outdated. Please run:
npx browserslist@latest --update-db
Latest version:     1.0.30001207
Installed version:  1.0.30001112
Removing old caniuse-lite from lock file
Installing new caniuse-lite version
$ npm install caniuse-lite
npm WARN bootstrap@4.4.1 requires a peer of popper.js@^1.16.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules\browser-sync\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

Cleaning package.json dependencies from caniuse-lite
$ npm uninstall caniuse-lite
npm WARN bootstrap@4.4.1 requires a peer of popper.js@^1.16.0 but none is installed. You must install peer dependencies yourself.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@2.1.3 (node_modules\browser-sync\node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@2.1.3: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: fsevents@1.2.13 (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for fsevents@1.2.13: wanted {"os":"darwin","arch":"any"} (current: {"os":"win32","arch":"x64"})

caniuse-lite has been successfully updated

Target browser changes:
- and_chr 84
+ and_chr 89
- and_ff 68
+ and_ff 86
- android 81
+ android 89
- chrome 84
- chrome 83
+ chrome 89
+ chrome 88
+ chrome 87
- edge 84
- edge 83
- edge 18
+ edge 89
+ edge 88
- firefox 79
- firefox 77
+ firefox 87
+ firefox 86
- ios_saf 13.4-13.5
- ios_saf 13.3
- ios_saf 12.2-12.4
+ ios_saf 14.0-14.5
+ ios_saf 13.4-13.7
- op_mob 46
+ op_mob 62
- opera 69
- opera 68
+ opera 73
+ opera 72
- safari 13
+ safari 14
- samsung 11.1-11.2
+ samsung 13.0

コメント

タイトルとURLをコピーしました